태그 보관물: centos4

Centos4에서 Bash 업데이트 진행하기

첨부파일 :
bash-3.0-27.el4_.src_
bash30-019
bash30-018
bash30-017

 

​Centos4이하 버전에서는 정식지원이 끝났기 때문에, yum update를 통해서는 업데이트가 불가능합니다.
이 때문에 최근 이슈가 된 Bash 취약점 업데이트는 시스템 담당자가 직접 소스RPM과 패치파일을 가지고 업데이트를 적용해야 하는데,
업데이트를 쬐금이라도 쉽게할수 있게 작성해서 업로드 합니다.

1. 패치할 소스RPM과 패치데이터 다운로드

2. 업데이트 내용변경

4번째 줄

55f98bd98c4b751a564b6294659a817e_1427874758_2483  110번 줄 내용추가 (%patch16 -p0 -b .016 내용은 주석처리되어 있는데, 주석해제 하면 됨.)

55f98bd98c4b751a564b6294659a817e_1427874785_2535

 

3. RPM생성한 후에 생성된 RPM으로 패치

​ bash-3.0-27.el4.src.txt파일은 다운로드 후 rpm으로 확장자를 변경하시면 되요.
업데이트가 잘되었는지는 아래 링크로 테스트 부분을 확인하셔서 해보시면 됩니다.

bash 취약점 테스트

Centos 4.x 리포지터리 변경 방법

Centos 4버전은 EOL(End Of Life)된 OS이기 때문에, 국내경로에서는 업데이트 제공이 안됩니다.
Centos.org에서 가지고 있는 이미지로 패키지 관리를 해야 하기 떄문에 기본 경로에서 변경을 해 주어야 합니다.

/etc/yum.repos.d/CentOS-Base.repo 파일 열어서 아래 내용으로 내용 변경